私の歴史と今

読んでて恥ずかしくなるのが私の歴史。だけどそのときは今現在のように真面目に書いていた訳でね。そんな私の今を書いていく。

Firefox + iMacrosの組み合わせ

Firefoxがマルチプロセス化してからiMacrosの使い勝手が悪くなった(window.contentを使用できない)ので私にとっての最適なバージョンをメモ。

Firefoxについて
  • Firefox 47?48? マルチプロセス化(「Electrolysis」通称“e10s”)
  • Firefox 50 古過ぎて、最新技術を使用しているサイトが表示できなかったりするので個人的にNG
  • Firefox 57 旧式の拡張機能を使用できなくなる
  • Firefox 59 2018/04/05時点の最新

51〜56が要件を満たす。

iMacrosについて
  • iMacros 8.9.7 最新よりも一つ前のバージョン(マルチプロセスに対応していない)
  • iMacros 9.0.3 マルチプロセスに対応したがwindow.contentにアクセスできない。(Error: Accessing content window is not supported in multiprocess Firefoxが発生)

8.9.7一択。

組み合わせ

Firefox 56 + iMacros 8.9.7の組合せになる。

ただし、基本認証が正常に動作しない(ダイアログに入力してくれない)ので、URLに入れ込む必要がある。

また、たまーに、遅延ロードされたときかな、TAGコマンドが機能しない。(場合によっては、致命的かもしれない・・・)

なお、正常にページを表示できるのであれば、もっと古いFirefoxの方が良い。そんな時は、Firefox46.0.1 + iMacros8.9.7。